Fork me on GitHub

About

This plugin compiles Less files to CSS stylesheets using extended version of the LessCSS Compiler.

The plugin was developed as an alternative version of the org.lesscss:lesscss-maven-plugin (by Marcel Overdijk) which is compatible with Less 1.7.5. It resolves all problems with imports options and adds extra features:

Read a migration page for information how to switch from the org.lesscss:lesscss-maven-plugin to this plugin.

Goals Overview

Requirements

The plugin to run requires:

  • Java 5.0 or higher
  • Maven 2.0.11 or higher

Usage

General instructions on how to use the LessCSS Maven Plugin can be found on the usage page. Some more specific use cases are described in the examples given below. Last but not least, users occasionally contribute additional examples, tips or errata to the plugin's wiki page.

In case you still have questions regarding the plugin's usage, please have a look at the FAQ.

If you feel like the plugin is missing a feature or has a defect, you can fill a feature request or bug report in the issue tracker. When creating a new issue, please provide a comprehensive description of your concern. Especially for fixing bugs it is crucial that the developers can reproduce your problem. For this reason, entire debug logs, POMs or most preferably little demo projects attached to the issue are very much appreciated. Of course, patches are also welcome. Contributors can check out the project from the source repository and will find supplementary information in the guide to helping with Maven.

Examples

To provide you with better understanding of some usages of the LessCSS Maven Plugin, you can take a look into the following examples:

You can also fetch example projects from GitHub.